One size fits all AMPlayer

From RISC OS

Viewed 996 times, With a total of 3 Posts
Jump to: navigation, search


Threads 7
Posts 9

Following on from the ARMv7 update in 2015 to AMPlayer, today a new version is available.

Version 1.41 incorporates several changes which were made to the main version after the point when Peter Naulls branched the code in 2002, and has been converted to work on both 26 bit and 32 bit versions of the ARM processor up to and including ARMv8 on the Raspberry Pi 3, from RISC OS 3.50 and later.

Specifically

 r215:
   Fix for SWI AMPlayer_Info not clearing FIB.
 r216:
   Evil addition of frame filters (might be removed in future).
   Addition of VBRI-style variable bit rate indicators, and improved Xing
   indicator parsing.
 r217:
   Only issue service calls from the module, not application.
 r219:
   Allow scroll requests to change the volume on the front end.
   Fix for corrupt level 2 decoding stiffing the machine.
 r220:
   Fix for corrupt level 3 decoding causing aborts.
 r225:
   Update MPEG123 tables of constants.
 r226:
   Fix for AMPlayer_Control stack size operations not following API, should
   return value in R1.

The new download also includes updated documentation to remove some dead links and retired email addresses.



Threads 0
Posts 1
  problems with 1.41 on Pi3 with 5.23 (31-oct-16)

hi installed 1.41 on pi3 and But had tgo go back to 1.39 1.41 gives filecore in use error has anyone seen this proble???



Threads 7
Posts 9

Quote:Microbits 2:35 13th November 2016

hi installed 1.41 on pi3 and But had tgo go back to 1.39 1.41 gives filecore in use error has anyone seen this proble???

What about 1.40? (can be downloaded from the same address, just change the URL to get amplayer-1_40.zip)

1.39 definitely shouldn't work on a Pi3 because it uses unaligned memory accesses, unless you've disabled the warnings about those. Running with alignment exceptions disabled is generally not recommended as there's a possibility that applications are silently reading the wrong memory contents and corrupting important system workspace.



Threads 7
Posts 9

Quote:Sprow 9:32 16th November 2016

Quote:Microbits 2:35 13th November 2016

hi installed 1.41 on pi3 and But had tgo go back to 1.39 1.41 gives filecore in use error has anyone seen this proble???

What about 1.40? (can be downloaded from the same address, just change the URL to get amplayer-1_40.zip)

Someone else had a similar problem to you on a Pi 3, but did actually reply to my questions, so 1.42 is now available now from the AMPlayer page.








AWC's: 2.4.1 MediaWiki - Stand Alone Forum Extension
Views
Personal tools
Toolbox