[gccsdk] build-it riscos failure on Cygwin

Adam lists at snowstone.org.uk
Wed Feb 20 16:26:01 PST 2008

In message <825d43744f.Jo at hobbes.bass-software.com>, John Tytgat wrote:

> In message <a19605744f.admin at snowstone.org.uk>
>           Adam <lists at snowstone.org.uk> wrote:
> > The build-output.txt and config.log files, in case it's helpful are at:
> > http://www.snowstone.org.uk/temp/gcc3.zip
> Good, config.log reveals:
> --8<--
> It was created by configure, which was
> generated by GNU Autoconf 2.61.  Invocation command line was
> --8<--
> Ahem, gcc 4.1 really really needs Autoconf 2.59. This version, not
> an earlier one, not a more recent one.

Oh, thanks. I've changed to 2.5. Unfortunately the Cygwin installer
makes avoiding having the most up to date versions of packages quite a

> --8<--
> configure:4310: arm-unknown-riscos-gcc -c -g -O2   conftest.c >&5
> conftest.c:8:17: error: gmp.h: No such file or directory
> conftest.c: In function 'main':
> conftest.c:14: error: 'choke' undeclared (first use in this function)
> conftest.c:14: error: (Each undeclared identifier is reported only once
> conftest.c:14: error: for each function it appears in.)
> conftest.c:14: error: expected ';' before 'me'
> configure:4316: $? = 1
> --8<--
> This fails and configure concludes that there is no working
> cross-compiler available.  However, the check on gmp.h is probably
> because of the newer version of Autotools

I just re-tried with autoconf 2.5 but got the same result. I'll delete
builddir-riscos and try again from scratch at some point.


Adam Richardson          Carpe Diem

More information about the gcc mailing list