[gccsdk] Package naming

Peter Naulls peter at chocky.org
Sun Jan 20 07:39:52 PST 2008

There were a number of inconsistencies and weak points in the legacy
handling we had in the autobuilder package naming.   I've changed this
so it's at least all in one place in the code.  I don't see anything in
the RiscPkg policy manual, but I've adopted aproximately the Debian
naming conventions.  The name of a package is like this:

{Name}_{Package version}[{Target}]-{Revision}.zip

Name is the default name of the autobuilder directory for that package.
This can be overridden by setting AB_ZIPNAME in the setvars file.

Package version is derived from the directory in the unpacked archive
name with the part following the first dash.  So for 'bc' it for example
becomes 1.06.94.  This is something of a guess for some sources, but can
be overridded by setting AB_PVERSION.   We used to use the rest of that
directory name for the package name, but that's a bit unreliable.

Target is an optional value for machine-specific builds.  This would be
set in your build-setvars file as AB_TARGET.  It might have the value
"-strongarm" or "-iyonix".

Revision is the RISC OS revision of this package, indicating incremental
changes to the RISC OS package of the same upstream version.  I've not
been real strict about doing this, and in almost every case it will be
1.  It can be set with AB_ROVERSION in setvars.

I'm still working through some of this, and I'll probably make some
revisions for handling of SVN and CVS sources etc.

Peter Naulls - peter at chocky.org        | http://www.chocky.org/
RISC OS Community Wiki - add your own content   | http://www.riscos.info/

More information about the gcc mailing list