[gccsdk] Building GCC4 in Cygwin

alan buckley alan_baa at hotmail.com
Wed Jan 30 04:05:48 PST 2008


I've now got GCC4 running on Cygwin as well so
I thought it may be a good idea to share my
experiences.

I set the following global variables first:

export GCCSDK_INSTALL_CROSSBIN=/home/riscos/cross/bin
export LTCONFIG_VERSION=1.4a-GCC3.0
export WANT_AUTOMAKE=1.9

(actually I got GCCSDK_INSTALL_CROSSBIN wrong first
time so I rebuilt it again with the above settings).

I was just building the cross compiler.

I had the same problems with autogen (seg
faulting at then end) as Adam. I got around it by
saving a copy of the makefile.in created using 
windows and then copying it back after
terminating the build process.

As it was newer than its dependencies it
meant it was used and autogen was not run
again.

The build-it script seemed to hang after about an
hour. I assumed it was a hang as the output file wasn't
increasing in size anymore (I gave it plenty of time for
something to happen). I then interrupted the script
and restarted cygwin and reset my variables.

I then used:

cd builddir-cross
make

to continue the build.

Interestingly, this hung the first time I tried it, but
completed successfully overnight the second time.

I've an AMD 64 bit dual core processor in the
desktop machine I've got cygwin on and like Adam
it took well over 6 hours to build. (I don't know the
exact amount as I went home and left it building).

To try it out I used the autobuilder to build wget.

I've now got it to build, but I had the following
problems. Can anyone tell me if they were caused
specifically by my installation or if they are
general problems?

The build went through most the steps, but then
just reported failure with no helpful message.

My first thought was I needed to set the
AB_ELFBUILD variable, so I set it to yes.

Is this correct? I sort of assumed the autobuilder
would know it's running GCC4 and set it automatically.

Once I had this variable the package failed with
elf2aof missing. I found this in gcc4 install and
followed the instructions to build it and tried
again.

elf2aof worked fine, but I was back to my initial
problem.

Looking at the files I realised that the riscos zip
program was missing.

Luckily I remember seeing a check-in of something
called native-zip in to the autobuilder. So I built
that and now the packaging of wget works
perfectly.

So I am now up and running.

Regards,
Alan


_________________________________________________________________
Who's friends with who and co-starred in what?
http://www.searchgamesbox.com/celebrityseparation.shtml



More information about the gcc mailing list