[gccsdk] Problems running C++ programs compiled with GCC4

Lee Noar leenoar at sky.com
Tue Jul 29 11:48:08 PDT 2008


alan buckley wrote:
> I'm still having problems with some of the C++ programs
> that I've cross compiled using GCCSDK4 on Cygwin.
> 
> I've now found a smaller program without many
> dependencies and am hoping there is someone
> who could investigate what is going on.
> 
> I've checked in a game called tutris into the autobuilder.
> It needs libsdl1.2debian built first, but that is all.
> The Wimpslot in the !Run obey file needs increasing
> otherwise you just get a not enough memory error.

Unfortunately, I'm having trouble building most things with the 
autobuilder and I suspect it's because, for me, its downloading source 
code from the ubuntu 7 (gutsy) repos which don't match the patch files 
in the autobuilder. An example is libpng; the patch is for version 
1.2.26, but it downloads version 1.2.15~beta5 (last-failure attached). 
Is it possible to force the autobuilder to use the debian repos so that 
everything matches?

Thanks,
Lee.
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: last-failure
URL: <http://www.riscos.info/pipermail/gcc/attachments/20080729/2ff49a38/attachment.ksh>


More information about the gcc mailing list