[gccsdk] GCCSDK GCC 4.1.1 Release 1

Adam lists at snowstone.org.uk
Wed Feb 11 14:27:46 PST 2009


In message <8cd4f61b50.admin at snowstone.org.uk>, Adam  wrote:

> In message <9e6b761b50.Jo at hobbes.bass-software.com>, John Tytgat  wrote:
> 
> > In message <f9b26a1b50.admin at snowstone.org.uk>
> >           Adam <lists at snowstone.org.uk> wrote:
> > 
> > > To be honest, I expected people would keep a copy of all the mailing
> > > list emails since there's no way to search the online archive :(
> > 
> > I don't have a handy search in my mail program given a Message-ID and
> > I presume others are in the same situation.  An URL is way handier.  Well,
> > all IMHO.
> > 
> > > I'm not sure I understand. To make the project, I would normally set the
> > > directory containing the source to be the CSD, then just do a "make".
> > > Should I add a "*HostFS" in between the two? [1]
> > 
> > Yes, please try that.
> 
> <Moving to using SharedUnixLibrary 1.11>
> 
> OK, I tried altering my makefile to include complete references to each
> file (e.g. replacing references to main.c with
> <WinEd$Dir>.Source.main.c etc)
> 
> and then did:
> *HostFS
> *Make -f <WinEd$Dir>.Source.Makefile
> 
> but got:
>   Make: stat:<WinEdir>.!RunImage: Input/output error
>   Make: stat:<WinEdir>.Source.Error.o: Input/output error
>   Make: stat:<WinEdir>.Source.Error.c: Input/output error
>   Make: *** No rule to make target `<WinEdir>.Source.Error.c', needed by `<WinEdir>.Source.Error.o'.  Stop.
> 
> Is the "$" in "<WinEd$Dir>" being interpreted somewhere as an escape
> character? I haven't persevered to try and figure out why this isn't
> working as I'd rather find a neater solution...
> 
> So I tried moving !GCC (3.4.6R3) onto my ADFS image but that caused
> serious problems - attemping to call *make crashed the emulator, requiring
> a reset and trashing my ADFS image! (Happily fixed by DiscKnight - which
> ironically, I've only ever needed since moving to VRPC!) This happened
> when using SharedUnixLibrary 1.10 as well, so I guess is a different
> problem.

Is there anything else I can do to try and sort this out. I'm stuck,
unable to use GCC4, which is frustrating.

I've tried raising this on the VA forums but to no avail:
http://www.virtualacorn.co.uk/forum/viewtopic.php?f=7&t=519
http://www.virtualacorn.co.uk/forum/viewtopic.php?f=12&t=525

Thanks,
Adam


-- 
Adam Richardson          Carpe Diem
http://www.snowstone.org.uk/riscos/




More information about the gcc mailing list