[gccsdk] Problems building crosscompiler

Jan-Jaap van der Geer jjvdgeer at inbox.com
Sat Nov 7 08:20:48 PST 2009


Hello,

I wanted a fresh crosscompiler, because I was still getting errors that
mmap() was not implemented which indicated that some part of the unixlib
probably was old since Peter made an implementation of that some time
ago.

So I tried a "./build-it riscos" which failed.

As it was some time ago I build the compiler, I thought before looking
in detail, I'd build the crosscompiler first and then see. So I did a
"./build-world". This failed as well. The last part of
build-cross-output.txt is:

make[5]: Leaving directory
`/home/jjvdgeer/gccsdk/gcc4/builddir-cross/arm-unknown-riscos/fpu/libiberty/testsuite'
make[4]: Leaving directory
`/home/jjvdgeer/gccsdk/gcc4/builddir-cross/arm-unknown-riscos/fpu/libiberty'
make[3]: Leaving directory
`/home/jjvdgeer/gccsdk/gcc4/builddir-cross/arm-unknown-riscos/libiberty'
make[2]: Leaving directory
`/home/jjvdgeer/gccsdk/gcc4/builddir-cross/arm-unknown-riscos/libiberty'
make[2]: Entering directory
`/home/jjvdgeer/gccsdk/gcc4/builddir-cross/arm-unknown-riscos/libstdc
++-v3'
cd /home/jjvdgeer/gccsdk/gcc4/srcdir/libstdc++-v3
&& /bin/sh /home/jjvdgeer/gccsdk/gcc4/srcdir/missing --run autoheader
configure.ac:83: error: m4_copy: won't overwrite defined macro:
_AC_ARG_VAR_PRECIOUS
acinclude.m4:48: GLIBCXX_CONFIGURE is expanded from...
configure.ac:83: the top level
autom4te: m4 failed with exit status: 1
autoheader2.50: '/usr/bin/autom4te' failed with exit status: 1
make[2]: *** [/home/jjvdgeer/gccsdk/gcc4/srcdir/libstdc
++-v3/config.h.in] Error 1
make[2]: Leaving directory
`/home/jjvdgeer/gccsdk/gcc4/builddir-cross/arm-unknown-riscos/libstdc
++-v3'
make[1]: *** [all-target-libstdc++-v3] Error 2
make[1]: Leaving directory `/home/jjvdgeer/gccsdk/gcc4/builddir-cross'
make: *** [all] Error 2

What went wrong with the RISC OS compiler I don't remember, but may or
may not have been the same thing.

I have recently upgraded to ubuntu 9.10.

Googling for a bit, I found this:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=539972

It looks to me like the same problem. However, my default gcc seems to
be gcc-4.4.1, I did not find any indication that this version was
affected by this bug.

I am not sure how to override my gcc version properly, but I tried
changing the symlink at /usr/bin/gcc to point to gcc-4.1 which
identifies itself as:

gcc (GCC) 4.1.3 20080704 (prerelease) (Ubuntu 4.1.2-27ubuntu1)

That seems to me like a version that should have the fix to this issue
(but that version of gcc seems to be from 2008 while the bug is from
august this year). Anyway, this still does not work, same problem.

Any ideas how to resolve this problem?

Cheers,
Jan-Jaap

____________________________________________________________
FREE ONLINE PHOTOSHARING - Share your photos online with your friends and family!
Visit http://www.inbox.com/photosharing to find out more!




More information about the gcc mailing list