[gccsdk] polkit-policy-file-validate

Chris Palmer cpalmer at maths.otago.ac.nz
Tue Oct 26 15:27:59 PDT 2010


Jan-Jaap van der Geer wrote:
> John Tytgat<John.Tytgat at aaug.net>  wrote:
>
>> In message<769a606c51.Jan-Jaap at iyonix.c2i.net>
>>            Jan-Jaap van der Geer<jjvdgeer at inbox.com>  wrote:
>
>>> I tried building the last version of Vala but it failed with:
>
>>> Autobuilder: polkit-policy-file-validate not found; is it
>>> installed on your path?
>
>>> I think this was caused by my upgrade to Ubuntu 10.10, but I'm
>>> not sure.
>
>>> I tried installing the PolicyKit package, but apt-get tells me
>>> it doesn't exist. PolicyKit-1 is installed, though.
>
>>> What do I need to get around this?
>
>>> For now I removed this dependency from the build script, which
>>> works as well, but...
>
>> Perhaps you can figure out who/when this requirement got added
>> and maybe that will learn us what the (presumebly) new
>> requirement is.
>
> It seems it was checked in by Chris Palmer 30-9-2009 with the log
> message "Also need polkit-policy-file-validate". No other changes
> than the addition of this dependency.
>
> It doesn't tell me much.
>
> Cheers,
> Jan-Jaap
>

I'm looking into it now, but early indications are that the policykit 
package has changed between 10.04 and 10.10 so that a command that 
previously was available is no longer available. I've yet to determine 
which package in the autobuilder requires this package - it's been a 
while since I last looked at the autobuilder, so I don't have a 
definitive answer for you yet, sorry.

Regards,

Chris.






More information about the gcc mailing list