[gccsdk] Unable to build trunk gcc on debian

Alan Buckley alan_baa at hotmail.com
Wed Sep 7 03:42:42 PDT 2011

I’ve tried today to build the trunk GCC after doing an svn update
on Debian and it failed. After retrying a make I get:

libtool: link: ( cd ".libs" && rm -f "libcloog.la" && ln -s "../libcloog.la" "li
bcloog.la" )
gcc -DHAVE_CONFIG_H -I. -I/home/alanb/gccsdk/gcc4/srcdir/cloog -I./include/cloog
-I./include -I/home/alanb/gccsdk/gcc4/srcdir/cloog/include  -I/home/alanb/gccsd
k/gcc4/builddir/installed-libs-for-cross-gcc/include -I/home/alanb/gccsdk/gcc4/b
uilddir/installed-libs-for-cross-gcc/include  -Wall -fomit-frame-pointer -g -O2
-MT cloog.o -MD -MP -MF .deps/cloog.Tpo -c -o cloog.o `test -f 'source/cloog.c'
|| echo '/home/alanb/gccsdk/gcc4/srcdir/cloog/'`source/cloog.c
mv -f .deps/cloog.Tpo .deps/cloog.Po
/bin/bash ./libtool --tag=CC   --mode=link gcc -Wall -fomit-frame-pointer -g -O2
  -L/home/alanb/gccsdk/gcc4/builddir/installed-libs-for-cross-gcc/lib -L/home/al
anb/gccsdk/gcc4/builddir/installed-libs-for-cross-gcc/lib  -o cloog cloog.o libc
loog.la -lgmp -lppl_c -lppl -lgmpxx -Wl,-lstdc++
libtool: link: gcc -Wall -fomit-frame-pointer -g -O2 -o cloog cloog.o -Wl,-lstdc
++  -L/home/alanb/gccsdk/gcc4/builddir/installed-libs-for-cross-gcc/lib ./.libs/
libcloog.a /home/alanb/gccsdk/gcc4/builddir/installed-libs-for-cross-gcc/lib/lib
ppl_c.a /home/alanb/gccsdk/gcc4/builddir/installed-libs-for-cross-gcc/lib/libppl
.a /home/alanb/gccsdk/gcc4/builddir/installed-libs-for-cross-gcc/lib/libgmpxx.a
/usr/bin/ld: cannot find -lstdc++

It looks like this cloog item can’t find –lstdc++. How do I fix this?

As a test I did manage to link it by using g++ in the makefile, but this is
overwritten once I tried to remake gcc4 again.

svn revision is 5300.

gcc –version
gcc (Debian 4.4.5-8) 4.4.5

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riscos.info/pipermail/gcc/attachments/20110907/d08900f6/attachment.html>

More information about the gcc mailing list