[gccsdk] autobuilder - GLib-Critical error

John Ballance jwb at macpcrepair.co.uk
Sun May 17 13:50:10 PDT 2015


Hi Theo

Thanks for the reply, and for the suggestions

A few points

1: Though there is a ubuntu desktop around (ctrl-alt-F7) I am working 
directly from a plain text (?) login at ctrl-alt-F1

2: What I said about the failure is accurate.

the setvars script has the AB_HG line in it, which is detected and used 
by autobuilder fetch-program script. Once that has completed the sources 
are in place. The autobuilder then invokes setvars. It runs fine (doing 
echo 'some text') until it encounters the AB_HG= line, at which point 
the GLib error ss reported and nothing goes further.

I've now tried again in a desktop terminal window. GLib throws all sorts 
of funnies out, eventually returning to setvars to continue...

I tried the code you suggested for Xvfb, but it then complains it cannot 
open display 99 (your example).

I presume Xvfb :99 needs an & after it to return to command line?

I'm still none the wiser as to why glib decided it needed to push 
something to the display though, and none the wiser what it actually 
tries to push.

Many thanks

John

On 17/05/2015 17:21, Theo Markettos wrote:
> On Sun, May 17, 2015 at 05:02:04PM +0100, John Ballance wrote:
>> Hi
>>
>> I'm having fun with porting a package that uses mercurial (hg) for
>> its sources. I have set up a minimal package that has little in
>> setvars other than the line starting AB_HG=
>>
>> The sources are correctly fetched, then the autobuilder/build enters
>> setvars, and proceeds to produce
>>
>> GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
>> Error: no display specified
>>
>> when it gets to the AB_HG= line
>>
>> Any suggestions/cures/etc would be appreciated
> How are you running it? SSH session or via a Linux desktop?
>
> The GLib- line is not necessarily a problem - I don't know that one, but
> some X programs are a bit 'chatty' as regards warnings.  Programs spit these
> messages out on the console but otherwise seem to work normally.
>
> 'No display specified' means you don't have an X session, and something
> wants to open a graphical window.  I don't know why that might be, it'll
> depend on what you're doing.
>
> A couple of solutions... one is to install vncserver and run things from
> within a VNC session.  That should mean your DISPLAY variable is set up
> right.
>
> An alternative is to install Xvfb and do:
> Xvfb :99
> export DISPLAY=localhost:99
>
> which will give you a virtual X session (that goes nowhere) but should at
> least stop complaints about lack of X server.
>
> Note if you SSH then ssh -X will forward X over your SSH tunnel, so you can
> start program on machine A and have it displayed on machine B.  So you can
> build somewhere that isn't your local machine if you choose.  For instance,
> ssh -X from a Mac to a Linux box and XQuartz on the Mac will display Linux
> programs.
>
> Can you pin it down to which component is complaining?  My guess would be
> it's something in your build, not to do with the AB_HG as such.
>
> Theo
>

-- 
Stop press! Just announced -

Most Trusted Broadband Provider in the 2014 Moneywise Customer Services 
Awards

For full details of see 
https://www.utilitywarehouse.co.uk/reviews?exref=095761
<https://www.utilitywarehouse.co.uk/reviews?exref=095761>

Intrigued? Call me

John Ballance C.Eng MIET - jwb at macpcrepair.co.uk - 07976 295923

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riscos.info/pipermail/gcc/attachments/20150517/08f48087/attachment.html>


More information about the gcc mailing list