[Rpcemu] Notes on Rev 119

Musus Umbra musus.rpcemu at verelanthe.co.uk
Fri Jan 18 01:21:37 GMT 2008


On Friday 18 Jan 2008, Terry Duell wrote:
> Hullo All,
> I just tried a Linux build of Rev 119, using ROS4.39 roms.
> It starts up as a StrongARM, but maybe that has something to to do
> with me having copied my hd4.hdf file with !Boot from a previous
> version that had been using SA110 emulation.

Which processor to emulate is set in the rpcemu.cfg file, but if you're 
using the dynarec then that setting is ignored as the dynarec only 
emulates a StrongARM, AIUI.

> I tried to set it as an ARM710 but when I selected "OK" rpcemu froze
> and a message was written to the terminal window...
> "***glibc detected***rpcemu: malloc() memory corruption:
> 0xb7f24008***" and that was followed by abacktrace and memory map.

I see the same thing - I think RPCemu is about to do a reset when it 
happens.

TTFN,
Adny

-- 
Erst wenn die Wolken schlafengehn	 | Personal: adny at verelanthe.co.uk
kann man uns am Himmel sehn		 | Techie: musus at verelanthe.co.uk
wir haben Angst und sind allein		 | WWW: verelanthe.co.uk/musus/
Gott weiss ich will kein Engel sein!	 | UT: adny.rsa at googlemail.com
-- Rammstein / Engel



More information about the Rpcemu mailing list