[Rpcemu] Problems booting from hostfs

Leo Smiers leo at fam.smiers.name
Wed Apr 7 11:30:08 PDT 2010


In message <l2l80ce369d1004071033m9a993223k66fb4d0aeea2ed7d at mail.gmail.com>
          Matthew Howkins <rpcemu-list at howkins.me.uk> wrote:

> > I boot my rpcemu RISC OS from the hostfs filing system. This went well until
> > the ebfda7d997a revision ('Synchronise and merge HostFS with the latest code
> > from ArmEm).
> >
> > I have looked into this for a bit and are quit sure the problem is not in the
> > hostfs module itself because if I run the pervious revision with the module
> > I have no problems. So this leaves the hostfs.c file. This file has changed
> > quite a lot (eg caching) so I can not find the problem myself. Maybe Matthew
> > can have a look into this.
> 
> Works for me - I tested it at the time, and it still works now.
> 
> Can you tell me what version of the HostFS module you have running?
> (*help rpcemuhostfs)
> 
> Also can include details of Host OS, Kernel, compiler, 32/64-bit,
> interpreted/dynarec, version of RISC OS, configuration settings, and
> anything else you can think of that may be relevant?

Thanks for the quick reply and yes I should have added these details right
away 8-(.

Host OS: Vista 32bit
RISC OS: 4.02
Dynarec
RPCEmu HostFS: 0.05 (14 mar 2010) as provided from the download
HostFSFiler: 0.03 (08 dec 2006) as provided from the download
No ADFS drives
The same !boot works without modification on the previous revision

The !boot seems to finish but does not complete all scripts.

Thought: Maybe the order in which files are returned has changed and now I
run into a script failure which prevent to complete the boot and because of
the change in the order I did not detect this with the previous revisions.
So my questions are:
1 has the order changed?
2 do you know how I can detect that the boot is not finished correctly?

with kind regards

Leo

-- 
Leo Smiers
!Flash 0.410.1.1
http://fam.smiers.name



More information about the Rpcemu mailing list