[Rpcemu] Problems compiling 0.8.8 and mouse issue

Matthew Howkins rpcemu-list at howkins.me.uk
Wed Dec 15 12:13:51 PST 2010


> I have just tried to compile 0.8.8 and get the following errors,
> rpcemu-rpcemu.o: In function `loadconfig':
> rpcemu.c:(.text+0x7a1): undefined reference to `list_config_entries'
> rpcemu.c:(.text+0x7f3): undefined reference to `free_config_entries'
> collect2: ld returned 1 exit status
> make[1]: *** [rpcemu] Error 1
> make[1]: Leaving directory `/Drives/sda2/pjgl2/new/rpc2010/rpcemu-0.8.8/src'
> make: *** [all] Error 2
>
>  This seems to be involved with liballegro. I have installed the latest debs
> from squeeze, e.g.
>
> Setting up x11proto-xf86vidmode-dev (2.3-2) ...
> Setting up libxxf86vm-dev (1:1.1.0-2) ...
> Setting up liballegro4.2-dev (2:4.2.0-5) ..

The functions list_config_entries() and free_config_entries() were
added to Allegro in version 4.2.1, but the RPCEmu configure script is
not that precise and only checks for Allegro 4.2.

I have found out just now that these functions were added in 4.2.1 by
looking through their source repository - the Allegro documentation
implies they were available in 4.2

Your comments above show that you installed Allegro 4.2.0 so you do
not have a new enough version. However the following page suggests
that Debian Squeeze should have Allegro 4.2.2:

http://packages.debian.org/squeeze/liballegro4.2-dev

Do you know why the version you have installed does not match the
version referred to in the web page above? I do not know enough about
Debian, but perhaps you are installing packages from an earlier
repository?

For now I will look into making the configure check for RPCEmu more
precise, and then in the future a clearer error message will be
produced.

Matthew



More information about the Rpcemu mailing list