[Rpcemu] Networking on MacOS again

Francis Devereux francis at devrx.org
Tue Oct 25 11:14:08 PDT 2011


On 25 Oct 2011, at 09:53, Chris Wraight wrote:

> Hi Francis,
> 
> 
>> I've had a look into it and fixed the bug that stopped it working on my machine
>>  and I'd be interested in hearing whether it fixes it for you too. I've uploaded a build
>>  with the fix to http://www.devrx.org/software/rpcemu/rpcemu-spoon-fjd-2011-10-25.zip .
> 
> That's interesting - thanks for looking into it. Unfortunately, this build doesn't work on my machine. It opens a window on the desktop, but before RISC OS does anything I get the error 'RPCEmu Error: Bad PC FFFFF000 FFFFF000', and RPCEmu exits. I'm using OS 5.17.

I was using RO 4.39 before. I've tried 5.17 and I got the same error. I tracked it down to this change:

http://home.marutan.net/hg/rpcemu/rev/f4e008543d94 (Refactor physical memory code to separate functions)

...so I've backed out that change from my tree and done another build - give http://www.devrx.org/software/rpcemu/rpcemu-spoon-fjd-2011-10-25b.zip a try.

Francis


More information about the Rpcemu mailing list