[Rpcemu] Some ques re RPCemu-0.8.9 on Linux

Terry Duell tduell at iinet.net.au
Mon Jan 9 13:37:07 PST 2012


Hullo Peter,

On Tue, 10 Jan 2012 01:37:12 +1100, Peter Howkins  
<rpcemu.howkins at marutan.net> wrote:

> Please compile up RPCEmu with additional debugging.
> cd rpcemu
> make clean
> ./configure --enable-debug
> make
> Rerun the test of clicking on the directory that causes the lock up.
> Post the rpclog.txt file that is created to us.

Attached rpclog.txt.
RPCemu crashed when I tried to open my linux home dir in hostfs.
I ran RPCemu from a terminal. The following are the last lines writ to the  
terminal...

Func 15
	Read directory entries and information
	r1 = 0x01c12fe8 (ptr to wildcarded dir. name)
	r2 = 0x0223d364 (ptr to buffer for returned data)
	r3 = 46 (number of object names to read)
	r4 = 266 (offset of first item to read in dir)
	r5 = 1024 (length of buffer)
	r6 = 0x00000000 (pointer to special field if present)
	PATH = $.Fedora
HostFS completed directory
Shutting down Allegro due to signal #11
Segmentation fault

Hope this helps.

Cheers,
-- 
Regards,
Terry Duell
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: rpclog.txt
URL: <http://www.riscos.info/pipermail/rpcemu/attachments/20120110/7616d0db/attachment.txt>


More information about the Rpcemu mailing list