[Rpcemu] Rpcemu Digest, Vol 56, Issue 8

george greenfield george.greenfield at tiscali.co.uk
Tue Jan 10 09:34:28 PST 2012


In message <mailman.165.1326210932.2028.rpcemu at riscos.info>
          rpcemu-request at riscos.info wrote:

> Send Rpcemu mailing list submissions to
>         rpcemu at riscos.info
> 
> To subscribe or unsubscribe via the World Wide Web, visit
>         http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu
> or, via email, send a message with subject or body 'help' to
>         rpcemu-request at riscos.info
> 
> You can reach the person managing the list at
>         rpcemu-owner at riscos.info
> 
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Rpcemu digest..."
> 
> 
> Today's Topics:
> 
>    1. Re: Some ques re RPCemu-0.8.9  on Linux (Terry Duell)
>    2. Re: RPCEmu 'viewfinder'? (george greenfield)
>    3. Re: RPCEmu 'viewfinder'? (george greenfield)
>    4. Re: RPCEmu 'viewfinder'? (Tony Moore)
>    5. Re: RPCEmu 'viewfinder'? (Tom Walker)
> 
> 
> ----------------------------------------------------------------------
> 
> Message: 1
> Date: Tue, 10 Jan 2012 08:37:07 +1100
> From: "Terry Duell" <tduell at iinet.net.au>
> To: rpcemu at riscos.info
> Subject: Re: [Rpcemu] Some ques re RPCemu-0.8.9  on Linux
> Message-ID: <op.v7t6b5u8rs0ygh at localhost>
> Content-Type: text/plain; charset="utf-8"; Format="flowed";
>         DelSp="yes"
> 
> Hullo Peter,
> 
> On Tue, 10 Jan 2012 01:37:12 +1100, Peter Howkins
> <rpcemu.howkins at marutan.net> wrote:
> 
>> Please compile up RPCEmu with additional debugging.
>> cd rpcemu
>> make clean
>> ./configure --enable-debug
>> make
>> Rerun the test of clicking on the directory that causes the lock up.
>> Post the rpclog.txt file that is created to us.
> 
> Attached rpclog.txt.
> RPCemu crashed when I tried to open my linux home dir in hostfs.
> I ran RPCemu from a terminal. The following are the last lines writ to the
> terminal...
> 
> Func 15
>         Read directory entries and information
>         r1 = 0x01c12fe8 (ptr to wildcarded dir. name)
>         r2 = 0x0223d364 (ptr to buffer for returned data)
>         r3 = 46 (number of object names to read)
>         r4 = 266 (offset of first item to read in dir)
>         r5 = 1024 (length of buffer)
>         r6 = 0x00000000 (pointer to special field if present)
>         PATH = $.Fedora
> HostFS completed directory
> Shutting down Allegro due to signal #11
> Segmentation fault
> 
> Hope this helps.
> 
> Cheers,

Reply to Message 4.

"The config file is at <Windows hard drive> Program files\RPCEmu\rpc 
in which vram_size can be altered to 2,4 or 8. However, in my 
installation of RPCEmu 0.8.9, running RISC OS 4.39, on a Vista host, 
changes to the vram_size are ignored and, when the program is run, the 
parameter is re-set to the maximum value shown in the Settings> 
Configure menu, ie 2MB.

Tony"

Indeed. I wonder how Jim managed it? I'm not too Windows-savvy: I 
found and opened the rpc file using Notepad, altered the VRAM value 
and then had the choice of saving it back as .txt or 'other files'. 
Having noted that it is a .cfg file I chose the latter. It failed to 
save, and I assume administrator privileges are required?

George


-- 
george greenfield



More information about the Rpcemu mailing list