[Rpcemu] RPCEmu 0.8.9 Query

Musus Umbra musus at verelanthe.co.uk
Sun Jan 22 07:19:41 PST 2012


On 22 January 2012 14:31, Andy <andy at forum.uklinux.net> wrote:
> I have compiled RPC Emu 0.8.9 on my Mageia x86-64 machine, with RiscOS VFree
> 4.02.  The settings are for SA110, 256Mb RAM and sound.
>
> My issue is that when RPCEmu starts up it only displays part of the desktop -
> the top left half, so there is a blank band running along the bottom and up
> the right hand side of the window.  So I am unable to access any of the icons
> on the icon bar.  This also happens whenever I change the screen resolution.
>
> I have worked out that by going to fullscreen and then back to windowed the
> whole of the desktop appears.
>
> Is there a cure for this problem?

Are you using Compiz, by any chance?  I had this problem with Compiz -
my workaround was to shade and unshade the RPCemu window.

AFAICT, it's a Compiz problem that crops up when the RPCemu window
changes size for whatever reason and compiz fails to notice that it
needs to redraw a different area.  Doing something that causes compiz
to re-evaluate its idea of the window's size (shade/unshade in my
case, fullscreen/window in yours) kicks compiz into getting it right.

It's worth noting that RPCemu's window changes size several times
during the RISC OS startup, hence the problem manifests as soon as
things get properly going.

In the end, for unrelated reasons, I stopped using Compiz....  this
was just one extra problems that solved ;)



More information about the Rpcemu mailing list