[Rpcemu] RPCEmu 0.8.9, timers and sound is NOK on Win-XP, but workaround

Timmermans, Andre andre.timmermans at atos.net
Sun Jan 22 23:58:37 PST 2012


Hi,

I was too early in my report, ths sound stuttering actually still occurs.
By experimenting as to why I add noproblem at first, I wound a workaround.
I start playing a video (I use PotPlayer) and then I pause the replay.
RPCEmu then works fine but as soon as I close the video RPCEmu starts
stuttering again.

André

> -----Original Message-----
> From: rpcemu-bounces at riscos.info 
> [mailto:rpcemu-bounces at riscos.info] On Behalf Of Timmermans, Andre
> Sent: jeudi 12 janvier 2012 11:31
> To: rpcemu at riscos.info
> Subject: [Rpcemu] RPCEmu 0.8.9, timers and sound is OK on Win-XP
> 
> Hi,
> 
> This is just a little report concerning the timer/sound 
> problems on Windows XP.
> 
> The previous version of RPCEmu had some problems which caused problems
> like te timers being updated below real time and sound DMA 
> buffers filling
> not being called often enough, causing stuttering while 
> playing sounds.
> 
> I am glad to report that RPCEmu 0.8.9 works fine on my machine.
> Since it is not mentionned in the list of changes for this version
> I can only assume that the fix comes from the newer version 
> of the allegro DLL.
> 
> I have noticed some problems with regard to accessing the CD 
> drive of my machine
> but I will report it later when I had some time to provide 
> some test cases.
> 
> Cheers,
> André
> 
> _______________________________________________
> Rpcemu mailing list
> Rpcemu at riscos.info
> http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu
> 
> 



More information about the Rpcemu mailing list