[Rpcemu] RPCEmu 0.8.9, timers and sound is NOK on Win-XP, but workaround

george greenfield george.greenfield at tiscali.co.uk
Mon Jan 23 01:15:07 PST 2012


In message <2796FB2D03D57A4D816B2B61ADF569DD0511A0 at DEFTHW99EZ2MSX.ww93 
1.my-it-solutions.net>
          "Timmermans, Andre" <andre.timmermans at atos.net> wrote:

> Hi,
> 
> I was too early in my report, ths sound stuttering actually still occurs.
> By experimenting as to why I add noproblem at first, I wound a workaround.
> I start playing a video (I use PotPlayer) and then I pause the replay.
> RPCEmu then works fine but as soon as I close the video RPCEmu starts
> stuttering again.
> 
> André

I also have problems with sound: in my case, with the playing of 
Rhapsody4 scores which played flawlessly on the Iyonix under 
AemulorPro (Rhapsody's a 26-bit app) using the same speakers. So the 
only changed element is the underlying computing setup - now a 3.4GHz 
Core i7 Win7 (64-bit) machine running RPCEmu 0.8.9 under RO4.02 - 
available horsepower certainly isn't the issue :-). The sound stutters 
as the score is played; it sounds like the introduction of extra 
notes. Playing speed doesn't seem to mitigate it, though I haven't 
done any systematic testing of this (though could and would if this 
might prove helpful).

George
> 
>> -----Original Message-----
>> From: rpcemu-bounces at riscos.info
>> [mailto:rpcemu-bounces at riscos.info] On Behalf Of Timmermans, Andre
>> Sent: jeudi 12 janvier 2012 11:31
>> To: rpcemu at riscos.info
>> Subject: [Rpcemu] RPCEmu 0.8.9, timers and sound is OK on Win-XP
>> 
>> Hi,
>> 
>> This is just a little report concerning the timer/sound
>> problems on Windows XP.
>> 
>> The previous version of RPCEmu had some problems which caused problems
>> like te timers being updated below real time and sound DMA
>> buffers filling
>> not being called often enough, causing stuttering while
>> playing sounds.
>> 
>> I am glad to report that RPCEmu 0.8.9 works fine on my machine.
>> Since it is not mentionned in the list of changes for this version
>> I can only assume that the fix comes from the newer version
>> of the allegro DLL.
>> 
>> I have noticed some problems with regard to accessing the CD
>> drive of my machine
>> but I will report it later when I had some time to provide
>> some test cases.
>> 
>> Cheers,
>> André
>> 
>> _______________________________________________
>> Rpcemu mailing list
>> Rpcemu at riscos.info
>> http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu
>> 
>> 
> 
> _______________________________________________
> Rpcemu mailing list
> Rpcemu at riscos.info
> http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu


-- 
george greenfield



More information about the Rpcemu mailing list