[Rpcemu] 0.8.10/5.20: MIPS readout oddity

George george.greenfield at tiscali.co.uk
Fri Aug 23 07:26:24 PDT 2013


In message <20130822182907.GD31223 at spod.org>
          Peter Howkins <rpcemu.howkins at marutan.net> wrote:

> On Thu, Aug 22, 2013 at 08:18:16AM +0100, george greenfield wrote:
>> In message <7b84d77e53.old_coaster at old_coaster.yahoo..co.uk>
>>           Tony Moore <old_coaster at yahoo.co.uk> wrote:
>> 
>> > On 21 Aug 2013, Peter Howkins <rpcemu.howkins at marutan.net> wrote:
>> > 
>> > [snip]
>> > 
>> >> If you're running on Vista or 7 and you used the windows installer,
>> >> don't check Program Files/RPCEmu/rpc.cfg but Users/<your
>> >> userame>/AppData/Local/VirtualStore/Program Files/RPCEmu/rpc.cfg
>> > 
> 
> George, can you confirm whether your config file issue was resolved by
> comparing this other file.

Hi Peter

I didn't use the Windows installer (I installed direct from the zips), 
so not sure whether the 
'Users/<youruserame>/AppData/Local/VirtualStore/Program 
Files/RPCEmu/rpc.cfg' file will actually be relevant....
> 
> As to your new issue, try not using 256MB of RAM, but a lower value.
> There's some interesting issues with risc os and that much ram on real
> hardware, and I'm wondering if similar occurs when emulated.

Reducing RAM to 128MB via Settings-Configure-RAM seems to have helped; 
0.8.10/5.20 recompiler is now up and running (hurrah) and networking 
is back up too (in fact I'm sending this post from it). This 
installation is in OS (C:)>Program Files>RPCEmu0810-520>rpcemu520, 
which was created from scratch i.e. was not in use for an earlier 
RPCEmu version. A quick check of rpc.cfg in the rpcemu520 folder shows 
no change in the base settings, i.e., still showing ARM610 and 32MB 
RAM, for instance. Any suggestions where I should look for the real 
McCoy?

George



More information about the Rpcemu mailing list