<html><head><meta http-equiv="Content-Type" content="text/html; charset=utf-8"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">Many thanks Tim!<div class=""><br class=""></div><div class="">You resolved my issues! Indeed, I had several installations of RPCEmu and this was from the wrong installation. After cleaning up, and finding the correct directory, I was able to get things running with a blank harddisk image (to make sure I was editing the correct hd4.hdf file) and then after prepending my own hard disk image with 512 zero bytes, I had my old machine running in the emulator! Amazing.</div><div class=""><br class=""></div><div class="">I have a couple of warnings that I suspect I probably also had on the old machine, but most things seem to work. The drive is full of my old BASIC programs, whose purpose/function mostly elude me now, but I’m looking forward to rediscovering them. :-)</div><div class=""><br class=""></div><div class="">I don’t suppose the emulator has a feature to emulate the presence of the Impressions Publisher dongle, so I can open up my old documents? That is the only real issue I have left to solve...</div><div class=""><br class=""></div><div class="">Great to have the HostFS integration to extract files from the hard drive, I’m impressed, both with the old RISC OS for having a mechanism to recognise/discover pluggable file systems, and RPCEmu for being able to present a virtual filesystem to RISC OS. A very nice tight integration. :-)</div><div class=""><br class=""></div><div class="">Pete</div><div class=""><br class=""><div><br class=""><blockquote type="cite" class=""><div class="">On 27. Apr 2020, at 21:05, Timothy Coltman <<a href="mailto:lists@maemagel.com" class="">lists@maemagel.com</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html; charset=us-ascii" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><br class=""><div class=""><br class=""><blockquote type="cite" class=""><div class="">On 27 Apr 2020, at 19:42, Peter Moore <<a href="mailto:petemoore@gmx.net" class="">petemoore@gmx.net</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html; charset=utf-8" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">Hi guys!<div class=""><br class=""></div><div class="">I installed the new RPCEmu, and managed to dump an image of my RISC PC 600 hard drive using `dd` on linux.</div><div class=""><br class=""></div><div class="">I copied the raw hard disk image to the RPCEmuDataDir as hd4.hdf and have RISC OS 3.60 roms in place.</div><div class=""><br class=""></div><div class="">I followed the instructions on <a href="https://www.marutan.net/rpcemu/manual/#hdf" class="">https://www.marutan.net/rpcemu/manual/#hdf</a> but when i run the first command I get the following error:</div><div class=""><br class=""></div><div class=""><span id="cid:C961F474-7C47-4BD5-91AC-DBC18295C3A2" class=""><Screenshot 2020-04-27 at 20.33.10.png></span></div><div class=""><br class=""></div><blockquote style="margin: 0 0 0 40px; border: none; padding: 0px;" class=""><div class=""><font face="Courier New" class="">RISC OS 24MB</font></div><div class=""><font face="Courier New" class=""><br class=""></font></div><div class=""><font face="Courier New" class="">Supervisor</font></div><div class=""><font face="Courier New" class=""><br class=""></font></div><div class=""><font face="Courier New" class="">*dir aufs::4.$</font></div><div class=""><font face="Courier New" class=""><br class=""></font></div><div class=""><font face="Courier New" class="">Disc drive not known (Error number &108AC)</font></div><div class=""><font face="Courier New" class="">*</font></div></blockquote><div class=""><br class=""></div><div class=""><br class=""></div></div></div></blockquote><div class=""><br class=""></div><div class="">Strange - your boot messages don't include ADFS.  Is your CMOS corrupted? I'd try copying the one from my recent Mac release, as that's the one supplied with the source, so should contain some sensible defaults.  If that doesn't work, check to see if the module is unplugged (*RomModules).</div><div class=""><br class=""></div><div class="">Incidentally, which release are you using?  The "plist" file you included looks like one of Francis Devereux's from the 0.8.x versions (judging from the file name).</div><div class=""><br class=""></div><blockquote type="cite" class=""><div class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class=""><div class=""><span style="font-variant-ligatures: no-common-ligatures" class=""><br class=""></span></div><div class=""><span style="font-variant-ligatures: no-common-ligatures" class="">Does the raw device file produced by dd need to be altered in any way for it to work?</span></div></div></div></blockquote><div class=""><br class=""></div><div class="">It looks like it (Sarah is the original author of RPCEmu):</div><div class=""><br class=""></div><div class=""><a href="https://stardot.org.uk/forums/viewtopic.php?t=18291#p254144" class="">https://stardot.org.uk/forums/viewtopic.php?t=18291#p254144</a></div><div class=""><br class=""></div><div class="">There are some instructions here:</div><div class=""><br class=""></div><div class=""><a href="http://www.riscos.info/pipermail/rpcemu/2011-March/001261.html" class="">http://www.riscos.info/pipermail/rpcemu/2011-March/001261.html</a></div><div class=""><br class=""></div><div class="">Tim</div></div></div>_______________________________________________<br class="">RPCEmu mailing list<br class=""><a href="mailto:RPCEmu@riscos.info" class="">RPCEmu@riscos.info</a><br class="">http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu<br class=""></div></blockquote></div><br class=""></div></body></html>