Problems with make

Tom Hughes tom at
Thu Dec 19 16:03:23 PST 2002

I've been trying to experiment with the make from gccsdk to see if it
is able to replace my current combination of Makatic and amu for driving
builds. I'm actually working with the 32-bit build on my Iyonix, but I
assume the 26 bit build will have the issues.

My problem is that nothing much seems to work...

I can use the wildcard function to get a list of files in the current
directory, but I can't make it give me the files in the 'c' subdirectory
despite trying all of these:

  $(wildcard *.c)
  $(wildcard c.*)
  $(wildcard c/*)

All of them just seem to give me an empty list. I've even trying playing
with the UnixEnv$sfix list to see if that helps.

I seem to have similar problems writing pattern rules, in that they never
seem to match properly. I've tried all of these:

  %.o: %.c

  o.%: c.%

  o/%: c/%

But once again they don't seem to work. Some will appear to match the
target but then fail to find the source, and some will fail to match
the target at all.

Am I completely missing something here, or are these things advanced
features that have never really worked?


Tom Hughes (tom at

More information about the gcc mailing list