Later SharedCLibrary versions

Theo Markettos theo at markettos.org.uk
Sat Oct 25 08:10:52 PDT 2003


On Sat, Oct 25, 2003 at 04:02:16PM +0100, Nick Burrett wrote:
> SWI value out of range for module SharedCLibrary
> 
> So it looks like I need a library that is slightly newer than version 
> 4.84 i.e. one that has 32bit support.  From where do I get compatible 
> versions of the SCL for RISC OS 3.7 ?

http://www.iyonix.com/32bit/system.shtml
gets you 5.45.  This works on RO3.1 upwards.  Though I'm slightly surprised
that libscl needs it as I thought we were trying to support both old and new
CLibs.  I'm not involved with that code though, so I may be completely
wrong.

Theo

-- 
Theo Markettos                 theo at markettos.org.uk
Clare Hall, Cambridge          theom at chiark.greenend.org.uk
CB3 9AL, UK                    http://www.markettos.org.uk/




More information about the gcc mailing list