GCC 4.1 files

Peter Naulls peter at chocky.org
Mon Jul 18 08:39:13 PDT 2005


In message <20050715115604.wfxbb1brqc0kk488 at mail.sqrt.co.uk>
          Nick Burrett <nick at sqrt.co.uk> wrote:

> Updating binutils is difficult, you would need to do a cvs update in
> each binutils subdirectory i.e. binutils, bfd, opcode, ld, gas etc.
> 
> It fails because the 'include' directory of binutils is different to 
> the 'include' directory of gcc.  It's best to leave binutils alone, as 
> it works :)

Well, neither of the gcc or binutils include directories has any changes
from you, so it's pretty straight forward.  I now have a script to
update everything, although it needs to check all the configure.in/.ac
scripts to see if they might be newer.

What's the deal with the SharedUnixLibary support in Qemu?  I've not yet
been able to run the checks because it bails on unsupported SUL SWIs,
and the SUL support in Qemu doesn't appear to get built.

There also seems to be an issue with floating point in GCC 4.1, although
I haven't looked very hard at the problem: only that wget crashes with
some basic maths.

-- 
Peter Naulls - peter at chocky.org        | http://www.chocky.org/
----------------------------------------------------------------------------
Drobe - http://www.drobe.co.uk/        | The Premier RISC OS News Site



More information about the gcc mailing list