Missing /home/riscos/cross/include when building CVS head; qemu & ,ff8

Theo Markettos theo at markettos.org.uk
Thu Jul 21 13:27:20 PDT 2005


Just checked out a clean copy of CVS head and trying to build it, it seems
it's failing to put anything in /home/riscos/cross/include with the
resulting failure that the cross compiler can't find its include files:

make[2]: Entering directory
/home/atm26/riscos/gccsdk-noff8/gccsdk/unixlib/source'
/home/riscos/cross/bin//gcc -O2 -DTARGET_RISCOSAOF -mpoke-function-name
-D__UNIXLIB_INTERNALS -std=c99 -pedantic -Wall -Wundef -Wpointer-arith
-Wcast-align -Wwrite-strings -Winline -Wno-unused -W -Wcast-qual -Wshadow
-Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wnested-externs -D_GNU_SOURCE=1 -std=c99 -o
/home/atm26/riscos/gccsdk-noff8/gccsdk/arm-riscos-aof/unixlib/apcs32/abs/unixlib/assert/assert.o
-c assert/assert.c -isystem clib -I incl-local -munixlib -mno-module
In file included from clib/stdio.h:34,
                 from assert/assert.c:15:
clib/stdarg.h:14:25: stdarg.h: No such file or directory
In file included from assert/assert.c:15:
clib/stdio.h:335: error: syntax error before "__gnuc_va_list"
  [8 more of the same]
make[2]: ***
[/home/atm26/riscos/gccsdk-noff8/gccsdk/arm-riscos-aof/unixlib/apcs32/abs/unixlib/assert/assert.o]
Error 1

Playing around with reverting my CVS, I worked out it was a change somewhere
between 1 June and 10 July, but there are quite a few changes there and I
can't see anything obvious.

In other news, I've been playing with qemu.  Seems to do what it says on the
tin, and works quite well.  One question: currently the porting tools expect
the cross compiler to spit
out executables with ,ff8 on the end.  This is fine, except they don't have
the executable permission set.  Also build trees (like autoconf), when they
compile a test program/intermediate program, run ./foo rather than ./foo,ff8
so fail to find the binary.  This could be solved by having another copy of
gcc built without --enable-filetype-ff8 and patching it to set the
executable flag, but I wondered if there was a neater way?

Thanks
Theo



More information about the gcc mailing list