newbie help

Luca nodoubt at libero.it
Thu Jun 9 00:04:32 PDT 2005


Hi!

I am new list member, and even a new riscos/gcc user, so hi to all.

I just downloaded GCC version 3.4.4-release-2 and tried to install it
on my RiscOS 4.39 equipped RiscPC machine.  
Well I am having all the troubles of the world. Concerning the installation
guide, I shall just unzip everything togheter and have a !GCC application
at the end.  Running !GCC I'd have all the system variable set and it's ok.
My problem is that unzipping all the stuff sounds like not being enough.
There's stuff like "cc1plus" that ends in "!GCC.lib.arm-riscos-aof.3_4";
There's a lot of stuff lost around these paths, and to start having
something working, I had to move to the "!GCC.bin" directory. At the
end I had the compiler working, and tried to compile the hellow or
helloworld example. Here I get tons of errors. Compiling helloworld 
(the c++ example) I get an error saying it cannot find "iostream" file.
I located iostream file inside the !GCC dir structure.... and tried
to put it where it should be concerning !GCC.!Run file, which includes
this:
| Search path used for the compiler headers and libraries.
Set GCCpkg$Path <GCC$Dir>.
Set GCCsys$Path <GCC$Dir>.sys.
Set GCClcl$Path <GCC$Dir>.local.

I put it int the !GCC dir. I created the SYS and LOCAL that weren't there,
put it, then I put iostream everywhere I could put it, but I keep getting
this error. 

I even tried threating the machine showing it a windows xp logo :-) but
still doesn't work.
Would anyone be so kind to show metheir !GCC directory structure or
just telling me where to put what?  There are also !CLIB and !UNIXLIB
and if there's something I need to know about, please share. 

Thank you
Luca

"(they) know the difference
 between right and wrong.
 They just don't give a damn." (Natural Born Killers)

937, '87 Alfa 75 Turbo, '90 Alfa 75 1.8ie, '75 Benelli 500 Quattro, RM250
Myself: http://www.lp666.net/
Finnish Mythology: http://www.finnishmyth.org






More information about the gcc mailing list