[gccsdk] Problems building libxml with autobuilder on Ubuntu

Simon Wilson ksattic at gmail.com
Sat Jul 7 15:03:55 PDT 2007


Following the instructions at:

http://www.riscos.info/index.php/Using_GCCSDK

I was able to build wget with no problems. However, I am having
trouble building gnash, due to the dependency on libxml.

First, I was encountering a problem because the "automake-1.9" command
was not found in the script at
autobuilder/libraries/xml/libxml2/setvars, so I changed the file so it
would run the "automake" command instead. I also updated to the latest
version (1.10) of automake.

I start the build with:

/home/simon/src/gccsdk/autobuilder/build -v gnash

Then I get the following output:

Autobuilder: RISC OS patch:
/home/simon/src/gccsdk/autobuilder/libraries/xml/libxml2/makefile.am.p
patching file Makefile.am
Autobuilder: Calling setvars
configure.in:33: version mismatch.  This is Automake 1.10,
configure.in:33: but the definition used by this AM_INIT_AUTOMAKE
configure.in:33: comes from Automake 1.9.6.  You should recreate
configure.in:33: aclocal.m4 with aclocal and run automake again.
Package libxml2: ***Failure***

So, I ran aclocal in build/libxml2/libxml2-2.6.27.dfsg, and this
appeared to work (aclocal.m4 was updated), but I still get the above
error.

Can anyone assist?

Thanks,

Simon




More information about the gcc mailing list