[gccsdk] Problems building libxml with autobuilder on Ubuntu

John Tytgat John.Tytgat at aaug.net
Sun Jul 8 05:12:20 PDT 2007


In message <f90ca9440707071503xd670428p9c40ffa0ff54c83 at mail.gmail.com>
          "Simon Wilson" <ksattic at gmail.com> wrote:

> Then I get the following output:
> 
> Autobuilder: RISC OS patch:
> /home/simon/src/gccsdk/autobuilder/libraries/xml/libxml2/makefile.am.p
> patching file Makefile.am
> Autobuilder: Calling setvars
> configure.in:33: version mismatch.  This is Automake 1.10,
> configure.in:33: but the definition used by this AM_INIT_AUTOMAKE
> configure.in:33: comes from Automake 1.9.6.  You should recreate
> configure.in:33: aclocal.m4 with aclocal and run automake again.
> Package libxml2: ***Failure***
> 
> So, I ran aclocal in build/libxml2/libxml2-2.6.27.dfsg, and this
> appeared to work (aclocal.m4 was updated), but I still get the above
> error.
> 
> Can anyone assist?

I've changed the automake-1.9 into a full autotools reconfiguration line
which should solve this problem.  Could you try that out please ? Cfr.
<URL:http://www.riscos.info/websvn/listing.php?repname=gccsdk&path=%2Ftrunk%2Fautobuilder%2Flibraries%2Fxml%2Flibxml2%2F&rev=0&sc=0>.

John.
-- 
John Tytgat, in his comfy chair at home                                 BASS
John.Tytgat at aaug.net                             ARM powered, RISC OS driven




More information about the gcc mailing list