[gccsdk] Cross compiling shared libraries

alan buckley alan_baa at hotmail.com
Wed Dec 3 05:24:24 PST 2008


I'm attempting to cross compile some shared libraries for
use on RISC OS in the aim to get the autobuilder to be
able to create them. So far I've failed miserably.
 
I've tried various libraries, but have finally settled
on using zlib (zlib1g in the autobuilder) to test as it
has no dependencies and is fairly small.
 
The zlib makefile creates the shared library with:
 
/home/riscos/cross/bin/arm-unknown-riscos-gcc -shared
 -o libz.so.1.2.3.3 adler32.lo compress.lo crc32.lo gzio.lo
 uncompr.lo deflate.lo trees.lo zutil.lo inflate.lo infback.lo
 inftrees.lo inffast.lo -lc
 
(all on one line)
 
I then built the minigzipsh test program for testing.
 
I copied the resulting libz.so.1.2.3.3 to SharedLibs:lib and
created the symbolic links by hand with:
 
ln -s libz/so/1/2/3/3 libz/so
ln -s libz/so/1/2/3/3 libz/so/1
 
When it tried to run the program I get:
 
minigzipsh: 'SharedLibs:lib.libz/so' is missing the som___got symbol
minigzipsh: can't load library 'libz.so'
 
What have I done wrong/missed out?
 
Regards,
Alan

 
 
 
_________________________________________________________________
Get Windows Live Messenger on your Mobile
http://clk.atdmt.com/UKM/go/msnnkmgl0010000001ukm/direct/01/



More information about the gcc mailing list