[gccsdk] Shared library/Elf output from the autobuilder

John Tytgat John.Tytgat at aaug.net
Thu Feb 28 14:04:30 PST 2008


In message <47C71E47.50606 at chocky.org>
          Peter Naulls <peter at chocky.org> wrote:

> The variable RO_NOSTATIC was created earlier, although I'm not sure if
> it's actually used by any setvars now (ideally not), but this ensures
> the correct switches for static/dynamic flags in ro-config.
> 
> Let's rename that to AB_NOSTATIC, which you would set in your
> build-setvars file (the optional file in your build location for
> autobuild stuff), and then also not run elf2aif when it it 'yes'

If it would be possible then I would like to go for a 'positive' named
variable like "AB_SHAREDLIBS" instead as it always hurts my brain when I
see tests like "AB_NOSTATIC" != "no"

John.
-- 
John Tytgat, in his comfy chair at home                                 BASS
John.Tytgat at aaug.net                             ARM powered, RISC OS driven




More information about the gcc mailing list