[gccsdk] ***Fatal error: Stack corruption detected***

Jan-Jaap van der Geer jjvdgeer at inbox.com
Thu Apr 29 15:16:26 PDT 2010


I build the latest version of Vala (0.8.1) and tried to compile one
of my programs. Vala worked for a bit, and then gave an error:

***Fatal error: Stack corruption detected***

I tried compiling the same code under Vala in Linux, where it
compiled with no problem.

Googling on the errortext gave me three links, 2 of which were RISC
OS related, the third one some pastebin which did not open (so may
well have been RISC OS as well).

I thought I'd update the crosscompiler, so I took an "svn up" and
build it again. Build the vala compiler again, but still the same
problem.

I tried an older compiler, 0.7.8, which did not fail. I rebuild
0.7.8 with my latest crosscompiler (though the sources may differ
slightly - I may have build the original one with the Debian
version while I downloaded the old one from the Vala site).

This new version of 0.7.8 worked fine as well.

I think the conclusion of this is that something is upsetting newer
versions of the Vala compiler, possibly unixlib or gcc. Does that
sound reasonable? If so, is there anything that can be done to
resolve it?

Cheers,
Jan-Jaap




More information about the gcc mailing list