[gccsdk] Something broken in trunk GCCSDK?

Martin Wuerthner martin at mw-software.com
Fri Sep 10 17:53:47 PDT 2010


In message <771c4a5451.martin at bach.planiverse.com>
          Martin Wuerthner <martin at mw-software.com> wrote:

> In message <568e485451.Jo at hobbes.bass-software.com>
>           John Tytgat <John.Tytgat at aaug.net> wrote:

>> In message <f526415451.martin at bach.planiverse.com> you wrote:

>>> [...] So, I am wondering whether anyone has an idea which change could
>>> have caused such an effect. Has there been a change in output stream
>>> handling in Unixlib?

>> My first guess is indeed a possible regression (or latent bug now being
>> triggered) with UnixLib changes I made on 2 Jan 2010 and 21 Jan 2010 :
>> r4398 and r4459.

> OK, I will try a build using r4459, and if that still fails, with
> r4397. If your theory is correct then r4397 should work and r4459
> should fail.

I have completed the experiment and it is exactly as expected: 
Building Ghostscript using GCCSDK r4397 results in a working 
executable. Using GCCSDK r4459 results in an executable with broken 
output.

Then, I tried building with r4398 and it still works, so r4398 was not 
responsible. Finally, I tried r4458 and even that worked. I double 
checked with r4459 and it fails. So, this proves that r4459 was 
responsible for the problem.

Martin
-- 
---------------------------------------------------------------------
Martin Wuerthner          MW Software          martin at mw-software.com
---------------------------------------------------------------------




More information about the gcc mailing list