[gccsdk] Something broken in trunk GCCSDK?

Martin Wuerthner martin at mw-software.com
Fri Sep 17 09:39:50 PDT 2010


In message <eae02b5551.Jo at hobbes.bass-software.com>
          John Tytgat <John.Tytgat at aaug.net> wrote:

> In message <ede0d35451.martin at bach.planiverse.com>
>           Martin Wuerthner <martin at mw-software.com> wrote:

>> Then, I tried building with r4398 and it still works, so r4398 was not
>> responsible. Finally, I tried r4458 and even that worked. I double
>> checked with r4459 and it fails. So, this proves that r4459 was
>> responsible for the problem.

> Thanks for spending time figuring this out.  The r4459 was indeed the
> culpit but understanding why wasn't so trivial.  In turned out that this
> change wrongly called an internal flush call resulting in a failure
> when we were in the (v)s(n)printf() usecase and this resulted in a
> -1 return value.  In Ghostscript the return value of vsprintf() was
> used as fwrite(..., stdout) nmemb parameter which made stdout go into
> error mode preventing any further output.

> Fixed with r4786 change.

Great, thank you for fixing this problem.

Martin
-- 
---------------------------------------------------------------------
Martin Wuerthner          MW Software          martin at mw-software.com
---------------------------------------------------------------------




More information about the gcc mailing list