[gccsdk] Running out of memory when compiling C++ program

Alan Buckley alan_baa at hotmail.com
Mon Mar 7 06:17:17 PST 2011


John Tytgat wrote on Friday, March 04, 2011 8:58 PM 

> In message <SNT136-ds16534D828D66BB5BDFFD33F0C20 at phx.gbl>
          "Alan Buckley" <alan_baa at hotmail.com> wrote:

> > However I get:
> > 
> > cc1plus: out of memory allocating 65536 bytes after a total
> > of 33492992 bytes.
> > 
> > What I don’t understand is why that only seems to be 33MB
> > and according to the Tasks list I still have 54MB of free space
> > at this time. I start with 111MB.
> 
> When using DA as heap, UnixLib by default clamps this at 32 MByte.
> 
> So try:
>   * Set cc1plus$HeapMax 96
> 
> I expect this to make a difference.
> 
> Or if you're on RISC OS 5, make sure (at least) the cc1plus$Heap is
> not set (see !GCC.!Run file):
> 
>   * UnSet cc1plus$Heap
> 
> In that case you will be using the normal WimpSlot.
> 

Thanks John my initial testing shows this worked on RISC OS 4,
I’ll try RISC OS 5 over the next few days, but I expect it to work.

The one thing is that you have to use SetEval not Set. If you use
Set it doesn’t work. 

I had tried to change the heap max, but I was probably using
Set or perhaps the wrong program (gcc or g++) with the
HeapMax variable.

Regards,
Alan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.riscos.info/pipermail/gcc/attachments/20110307/5b3e95c4/attachment.html>


More information about the gcc mailing list