[gccsdk] Running out of memory when compiling C++ program

Ron beeb at woosh.co.nz
Sat Mar 12 15:56:33 PST 2011


In message <0748dbb251.Jo at hobbes.bass-software.com>
          John Tytgat <John.Tytgat at aaug.net> wrote:

> In message <SNT136-ds8CABE46042F91CCCA13A2F0C70 at phx.gbl>
>           "Alan Buckley" <alan_baa at hotmail.com> wrote:
> 
> > Thanks John my initial testing shows this worked on RISC OS 4,
> > I’ll try RISC OS 5 over the next few days, but I expect it to work.
> > 
> > The one thing is that you have to use SetEval not Set. If you use
> > Set it doesn’t work. 
> > 
> > I had tried to change the heap max, but I was probably using
> > Set or perhaps the wrong program (gcc or g++) with the
> > HeapMax variable.
> 
> That's very wierd that SetEval would work but not Set for setting HeapMax.
> 
> John.

I dont know the details of HeapMax, but it would depend on what is 
reading the value back.
Eval appears to convert the string value back to a number.

Set num 22
Eval num*22
Result is an integer, value : 44

So Set is giving num the string "22"
But SetEval num 22 would store the actual number 22.

Ron M.




More information about the gcc mailing list