[gccsdk] GCC Cross Compiler build failing at asasm

Steve Fryatt lists at stevefryatt.org.uk
Sun Dec 16 10:40:17 PST 2012

On 15 Dec, John Tytgat wrote in message
    <d63976fe52.Jo at hobbes.bass-software.com>:

> Was this all built from a fresh checkout ? Or an older checkout which you
> updated with 'svn update' ? If the latter, did you do a 'make clean'
> before building ? I'm just trying to get a better context on this problem.

It was an update of an existing setup, which I'd tried to build, then made
clean and tried again.


> The directory structure of asasm sources has changed some time ago and my
> guess is that you've still old autotool related files there which are
> outdated (i.e. not suited for the current directory structure) and not
> re-generated.  Instead of advocating a good 'make clean' + ./build-world
> again, you might get away with:
>   $ cd riscos/asasm
>   $ svn status --no-ignore | grep ^I | cut -b 9- | xargs rm -rf
> And redo the ./build-world

That didn't seem to work as intended: the errors went, but the build then
completed with "nothing to do" (and no asasm or anything later).

Anyway, I've just checked out a clean copy of 4.1.2 and that seems to have
built correctly. I'll need to transfer all of my non-standard libraries
across before testing it on some code, though.

Thanks for the help in the right direction.

Steve Fryatt - Leeds, England             Wakefield Acorn & RISC OS Show
                                             Saturday 20 April 2013
http://www.stevefryatt.org.uk/           http://www.wakefieldshow.org.uk/

More information about the gcc mailing list