[gccsdk] Autobuilder and Scummvm

Chris Gransden chrisg at care4free.net
Sat May 5 12:08:03 PDT 2012


In article
<CAHQJq4K-9ErvUdKXzQ5kUQeJrAn2B9yra6_MJoUdD0=b96NZ=A at mail.gmail.com>,
   Robert Heaton <rob at robheaton.co.uk> wrote:

> The error I'm getting now is;

> X11 will be built with the following settings:
>  Loadable i18n module support:            no
>  Loadable xcursor library support:        no
>  Threading support:                       yes
>  Use Threads safe API:                    yes
>  Threads stubs in libX11:                 no
>  XCMS:                                    yes
>  Internationalization support:            yes
>  XF86BigFont support:                     no
>  XKB support:                             yes
>  XLOCALEDIR environment variable support: no
>  Compose table cache enabled:             no
>  Functional specs building enabled:       yes

> Autobuilder: Running make command:
> /home/robheaton/Downloads/gccsdk/env/ro-make
> src/util/makekeys.c:31:19: fatal error: X11/X.h: No such file or directory
> compilation terminated.
> Package libx11-6: ***Failure***
> Dependency "libx11-6" failed for libsdl1.2debian
> Dependency "libsdl1.2debian" failed for scummvm
> Build for package "scummvm" failed

I think this means you need to install the X11 development headers on the
host. libX11-dev or similar.

Chris.





More information about the gcc mailing list