[gccsdk] Autobuilder libxcb1

Ron beeb at woosh.co.nz
Mon Jan 13 03:39:56 PST 2014


I have upgraded, updated make clean and ran build-world with out
problems. When building a library I was missing makeinfo command which
is part of texinfo, so a more complete install list for
GCCSDK/autobuilder is:

sudo apt-get -y install subversion libtool flex bison autogen help2man
autopoint automake1.7 cvs dpkg-dev libglib2.0-dev liborbit2-dev rman
autoconf2.13 gperf gettext intltool libpopt-dev realpath doxygen
xsltproc texinfo


Building libpthreadstubs0 required:

AB_URL=http://ftp.de.debian.org/debian/pool/main/libp/libpthread-stubs/libpthread-stubs_0.3.orig.tar.gz

(found by googling debian stable libpthread-stubs0)
as it wasn't being retrieved by the standard method.

But I have run aground with libxcb1 during python running through the
xml files. (at sync.xml)
I'm showing Python version 2.7.4 and the config output shows a check for
version >=2.6

I'm not holding my breath on building the X stuff, I haven't ever
before, and there is probably a lot more problems after this one.

I have a calculator emulator that ports to linux, and uses a fixed size
display, so thought it might be a good candidate for Chox11 etc.
I'm not sure what will happen with the pull down menu at the top though.

Thanks   Ron M.





More information about the gcc mailing list