[gccsdk] Autobuilder libxcb1

Alan Buckley alan_baa at hotmail.com
Mon Jan 13 05:37:32 PST 2014


Ron wrote on  Monday, January 13, 2014 11:39 AM:

[snip]

> But I have run aground with libxcb1 during python running through the
> xml files. (at sync.xml)
> I'm showing Python version 2.7.4 and the config output shows a check for
> version >=2.6

I don't seem to be able to build libxcb1 at all. I get the following errors:

RISC OS Cross installer mkdir:  -p 
/home/alanb/build/libxcb1/package/share/man/m
an3
/home/alanb/gccsdk/env/ro-install -m 644 man/xcb-examples.3 
man/xcb-requests.3
man/xcb_alloc_color.3 man/xcb_alloc_color_cells.3 
man/xcb_alloc_color_cells_mask
s.3 man/xcb_alloc_color_cells_masks_end.3 
man/xcb_alloc_color_cells_masks_length
.3 man/xcb_alloc_color_cells_pixels.3 man/xcb_alloc_color_cells_pixels_end.3 
man
/xcb_alloc_color_cells_pixels_length.3 man/xcb_alloc_color_cells_reply.3 
man/xcb
_alloc_color_cells_unchecked.3 man/xcb_alloc_color_planes.3 
man/xcb_alloc_color_
planes_pixels.3 man/xcb_alloc_color_planes_pixels_end.3 
man/xcb_alloc_color_plan
es_pixels_length.3 man/xcb_alloc_color_planes_reply.3 
man/xcb_alloc_color_planes
_unchecked.3 man/xcb_alloc_color_reply.3 man/xcb_alloc_color_unchecked.3 
man/xcb
_alloc_named_color.3 man/xcb_alloc_named_color_reply.3 
man/xcb_alloc_named_color
_unchecked.3 man/xcb_allow_events.3 man/xcb_allow_events_checked.3 
man/xcb_bell.
3 man/xcb_bell_checked.3 man/xcb_big_requests_enable.3 
man/xcb_big_requests_enab
le_reply.3 man/xcb_big_requests_enable_unchecked.3 
man/xcb_button_press_event_t.
3 man/xcb_button_release_event_t.3 man/xcb_change_active_pointer_grab.3 
man/xcb_
change_active_pointer_grab_checked.3 man/xcb_change_gc.3 
man/xcb_change_gc_check
ed.3 man/xcb_change_hosts.3 man/xcb_change_hosts_checked.3 
man/xcb_change_keyboa
rd_control.3 man/xcb_change_keyboard_control_checked.3 
'/home/alanb/gccsdk/env/s
hare/man/man3'
1
macro "ad" not recognized -- ignoring
macro "ad" not recognized -- ignoring
macro "ad" not recognized -- ignoring
macro "hy" not recognized -- ignoring
macro "ad" not recognized -- ignoring
macro "hy" not recognized -- ignoring
rman: couldn't read in referenced file man3/xcb_alloc_color_cells.3.
        Try cd'ing into ancestor directory that makes relative path valid 
first.
make[3]: *** [install-man3] Error 1
make[3]: Leaving directory `/home/alanb/build/libxcb1/libxcb-1.10/src'

Did you need to do anything else to get it to build?

> I'm not holding my breath on building the X stuff, I haven't ever
> before, and there is probably a lot more problems after this one.

I used to be able to build most of this, but it's been a long time
since I've tried to do it all from scratch.

Regards,
Alan 





More information about the gcc mailing list