[gccsdk] New VFP/NEON capable GCC release?

alan buckley alan_baa at hotmail.com
Mon Aug 24 05:33:02 PDT 2015


> Lee Noar wrote on Thursday, August 20, 2015 1:54 PM

> On 19/08/15 23:11, Theo Markettos wrote:

> [snip]

> > Today's build is number 32, where I bumped the release number to 2. 
> > This
> > works on my Raspberry Pi with no problems (looks like my RPCEmu hostfs 
> > image
> > is broken somehow, which is why I was a bit suspicious of the previous
> > build)

> I also had an issue with !PackMan in RPCEmu. I tried to install the 3
> shared library packages (base, C, C++), but it would only let me install
> one of them. If I tried to install a second, it would insist on
> removing the first at the same time. On the RPi the same package files
> installed with no problems. Possibly something to do with !PackMan's
> interaction with hostfs.

I've just tried this on RISC OS 5 installed on RPCEmu on Windows using
HostFS and the installation seemed to work correctly.

!PackMan shouldn't have a problem with it's interaction with hostfs as
it treats it the same as any other filing system.

I have seen problems previous on Windows where hostfs couldn't deal
with a character in a filename which caused problems.

If you go onto the PackMan advanced menu from the icon bar, there is
a view log option. Go into it first time to turn the log in. Run your 
install
and then after it fails go back to that menu option and it may show you
some more useful information on what went wrong.

After I had installed it I tried to build the C++ examples with GCC and
they failed with:

g++ -mlibscl -O3 -o template_scl template.cc
/tmp/ccfdiE8p.o: In function `_GLOBAL__sub_I_ip':
template.cc:(.text.startup+0x98): undefined reference to `__cxa_atexit'
/HostFS::HostFS.$/Apps/Development/!GCC/bin/../lib/gcc/arm-unknown-riscos/4.7.4/../../../scl/hard/fpa/libstdc++.a(eh_globals.o): 
In function `__static_initialization_and_destruction_0':
/home/jenkins/workspace/gcc-4.7-native/gcc4/srcdir/gcc/libstdc++-v3/libsupc++/eh_globals.cc:110: 
undefined reference to `__cxa_atexit'
collect2: error: ld returned 1 exit status
make: *** [template_scl] Error 1

The C examples compiled OK.

Regards,
Alan 





More information about the gcc mailing list