[gccsdk] Recursion of SIGSEV

Ron gettingchoppy at gmail.com
Tue Nov 17 00:07:07 PST 2015


In message <564764BB.2040209 at gmx.com>
          Duncan Moore <duncan.moore at gmx.com> wrote:

> On 11/11/2015 12:39, Gavin Wraith wrote:
> > I need some help. I am getting, after a few minutes
> > of running a wimp task, an error message
> >
> >   UnixLib detected recursion of signal SIGSEV. Exiting
> >
> > After which other tasks start complaining. My task
> > is the Lua interpreter with the code for calling SWIs
> > loaded dynamically. I cannot see that that should have
> > any behaviour different from the situation where it is
> > linked statically, and the past statically linked
> > programs worked fine.
>
> I've not used dynamic linking myself, so this may not be relevant. But
> when I've had this error message before it seems to be related to the
> use of vfork(). Changing to fork() can help, although fork() has
> problems of it's own with redirection.
>
> Duncan
>

Something that I haven't tried yet, but apparently the system() call
works differently. I'n not sure if there is an OSLib version that is
different to the gcc version.

I haven't been seeing these posts of mine to gcc at gccsdk.riscos.info, so this is a test also.

Ron M.




More information about the gcc mailing list