[gccsdk] SimpleGit

Theo Markettos theo at markettos.org.uk
Sun Nov 11 12:56:00 PST 2018


On Sun, Nov 11, 2018 at 08:33:53PM +0000, Jeffrey Lee wrote:
> However, there is still at least one problem with the simplegit-libgit2
> package: When I pulled in Chris's changes I also ended up pulling in the
> change to autobuilder/fetch-program from rev 7196. This means that instead
> of using libgit2-0.27.4 from the testing distro, the autobuilder now uses
> libgit2-0.24.6 from the stable distro, which is older than the libgit2 that
> simplegit supports, causing at least one build error due to API changes
> (simplegit's integrated version claims to be 0.26.3).

The reason for switching from 'testing stable' to 'stable oldstable' Debian
releases is that a lot of the autobuilder packages date from older Debian
releases.  When Debian release a new version they bump 'stable' to new
codebases, which causes us a lot of work to keep up (and in some cases,
packages can't be fixed).  Since we don't have the manpower to keep up with
Debian versions, I dropped the sources back to the version before the most
recent Debian release where more things worked.

If you need a particularly current source tree, using an explicit reference
to git sources is the thing to do.  Either a particular tag/branch (for
stability), or master if you are optimistic that upstream won't break
something.

Theo



More information about the gcc mailing list