[gccsdk] Recommended distros for autobuilder

Chris Gransden chrisg at care4free.net
Wed Sep 2 11:30:49 PDT 2020


In article <20200902172547.m43xjcsk7xr7lxbl at chiark.greenend.org.uk>,
   Theo Markettos <theo at markettos.org.uk> wrote:
> On Wed, Sep 02, 2020 at 06:00:15PM +0100, Chris Gransden wrote:
> > None of those are due to the version of Ubuntu you are using. The upstream
> > versions have changed so the patches need updating.

> I suppose what I'm getting at is two things:

> 1) What are the build platform and source repository that is likely to cause
> least breakage building things?

> 2) If the answers to 1) are 'use something ancient', what would be the least
> painful way to make it less ancient?


> If people (Chris, Alan, Lee, others) are currently building stuff and fixing
> up problems, it would be good to understand which versions the patches going
> in to the autobuilder are intended for.

> Theo

A lot of recipes have been updated to build with 'Stable' so that is the
best one to use for now. Any that don't build in stable can be set back to
the previous build that worked using AB_URL or similar.

There are only a few that don't build in Debian Bullseye but do in Ubuntu
16.0.4 LTS.
As an example Qt5Webkit needed an older version of bison.




More information about the gcc mailing list