[gccsdk] Recommended distros for autobuilder

David Pitt pittdj at pittdj.co.uk
Wed Sep 2 14:09:19 PDT 2020


Chris Gransden, on 2 Sep, wrote:

> On 02 Sep, chrisg at care4free.net wrote:
> > In article <58a9c68443chrisg at care4free.net>,
> >    Chris Gransden <chrisg at care4free.net> wrote:
> > > In article <mpro.qg1iky002hsio1s3t.pittdj at pittdj.co.uk>,
> > >    David Pitt <pittdj at pittdj.co.uk> wrote:
> > > > David Pitt, on 2 Sep, wrote:
> 
> > > > [snip]
> 
> > > > > My general view is that little now builds on Ubuntu 20.04 or
> > > > > 18.04.
> 
> > > > Some examples from Ubuntu 18.04
> 
> > > > curl
> > > >
> 
> > > > wget
> 
> 
> > > > pdf
> 
> 
> > > None of those are due to the version of Ubuntu you are using. The
> > > upstream versions have changed so the patches need updating.
> 
> 
> > wget should build now.
> 
> 
> curl should now build as well.

It did with r7415 but r7416 errors.

checking that c-ares is good and recent enough... no
configure: error: c-ares library defective or too old
Autobuilder: Running make command: /home/djp/gccsdk/env/ro-make
Autobuilder: No known build method
Package curl: ***Failure***
Build for package "curl" failed

That was resolved by building c-ares. curl then built.

Thanks. 

-- 
David Pitt



More information about the gcc mailing list