[Rpcemu] RISC OS 4

Musus Umbra musus.rpcemu at verelanthe.co.uk
Mon Nov 26 08:23:06 GMT 2007


On Saturday 24 Nov 2007, Alex Waugh wrote:
> I've has RISC OS 3.71 working fine on RPCemu, but when I try 4.02 it
> doesn't get any further than the green POST screen.

That could be CMOS related?  IIRC, by the time the green screen is 
displayed, the hardware should be initialised and RO is about to kick 
into the configured 'language'.  Bad CMOS or drive images might cause 
RISC OS to 'hang' for a while (or indefinitely) at this point, I guess 
(although, it's been a while so my memory of RO is a but fuzzy ;)


> Comments in the 
> source indicate it should work, does anyone have it working on the
> latest code? Has anyone seen similar symptoms before? I have tried on
> previous versions of RPCemu with the same result.

4.02 pretty much works for me (latest, and every previous SVN that I 
could actually build ;) with dynamic-recompilation enabled.  

I say "pretty much" because although everything seems to work well, 
RPCEmu segfaults if I drag windows in a certain way (diagonally up and 
to the right over the iconbar & empty pinboard, at any 'reasonable' 
speed).

TTFN,
Adny

-- 
Erst wenn die Wolken schlafengehn	 | Personal: adny at verelanthe.co.uk
kann man uns am Himmel sehn		 | Techie: musus at verelanthe.co.uk
wir haben Angst und sind allein		 | WWW: verelanthe.co.uk/musus/
Gott weiss ich will kein Engel sein!	 | UT: adny.rsa at googlemail.com
-- Rammstein / Engel



More information about the Rpcemu mailing list