[Rpcemu] Just starting

P.J.G. Long pjgl2 at cam.ac.uk
Wed Aug 6 22:27:13 BST 2008


On Aug 6 2008, Theo Markettos wrote:

 Very many thanks for the fast reply


>On Wed, Aug 06, 2008 at 07:03:14PM +0100, P.J.G. Long wrote:
>> 
>> I hope you won't mind some silly questions
>> 
>>  I have compiled rpcemu on effectively a debian etch system, using 3.7
>>  roms
>> 
>>  1) It seems to start very quickly, giving mips readings >110 all the 
>> time
>
>Good :)
>
>>  3) However at start up I get 
>> 
>>     a) a message in the terminal window saying 
>>            updatewindowsize: 640 256
>>            updatewindowsize: 640 480
>
>That's just some debugging output - RISC OS has changed screen mode and
>that's the emulator noticing.
>
>>     b) a Warning window 
>> 
>>          Invalid shut down state detected in CMOS
>
> Your emulated CMOS RAM checksums don't match - that'll be because the 
> default CMOS image isn't for RO3.7. Boot rpcemu with Delete held down 
> (simulating a power-on-Delete in RISC OS) and RISC OS should reset its 
> CMOS.
>

  Success

>>  4) Any attempt to increase the screen resolution from 16 cols 640x480 
>> is met with greyed out menus, is there a way around this? Screensize 
>> seems to be 320K, vram=2M
>
> Do you have a boot sequence on the emulator? 

  I have downloaded the formatted disk + universal boot sequence. The disk 
appears as drive 4 on the icon bar, but gives the error

 Error when reading ADFS::4.$ - Disc not understood - has it been formatted?
 
 when selected.


  Until a modefile is loaded 
> you won't be able to select modes other than numbered one (eg mode 32, 
> 800x600x256 cols). Either install a full boot sequence, or put a modefile 
> on the emulator and do *LoadModeFile <path to modefile>
>
>>  5) How is HOSTFS started, I seem to have tried all possibilities of 
>>      *configure filesystem hostfs
>
> Is the HostFS module getting loaded? It should be - check it shows up 
> under *Modules.
> 
    It doesn't seem to be there!  

>You'll need a directory called 'hostfs' at the same level as the rpcemu
>executable.  Put your files in there.

   Is this case specific in Linux, it was HOSTFS from the download? 

>
> Normally HostFS is run from the emulated ADFS image (in !Boot.Choices 
> somewhere), so you can't configure it as the default FS. But if you copy 
> the module into a 'podulerom' directory then RPCEmu will build a fake 
> podule ROM to load the module at startup, and you should be able to 
> *Configure Filesystem it. (I haven't tried this).
>
>Hope that covers everything :)
>
>Theo
>
>_______________________________________________
>Rpcemu mailing list
>Rpcemu at riscos.info
>http://www.riscos.info/cgi-bin/mailman/listinfo/rpcemu
>





More information about the Rpcemu mailing list