[Rpcemu] A pleasant blue window...

David david at ukpoets.net
Tue Mar 16 12:56:47 PDT 2010


In article <20100316162158.GA31516 at spod.org>, Peter Howkins
<rpcemu.howkins at marutan.net> wrote:
> On Mon, Mar 15, 2010 at 09:31:35PM +0000, David wrote:
> > ...is all I get when trying to get RPCEmu running on my Ubuntu 9.10.
> > 
> > Previous attempts have managed to get the emulator working, albeit
> > with a couple of errors on start-up and no CD drive, only to see it
> > fail (freeze) when I tried to enlarge the hard drive as per
> > instructions.
> > 
> > This latest attempt is using the rpcemu-0.8.6.tar.gz file rather
> > than using the 'svn co svn://.riscos..." method of the Linux Guide.
> > Is this not the correct file? It does seem to be complete.
> > 
> > Am using RO 3.7 rom images from one of my RiscPCs.

> I've had a quick check through the newsgroups for what a blue boot
> screen was meant to mean (the colours normally mean different
> things), but no real luck.

> Have you tried holding down 'delete' on startup to reset the CMOS
> files? (or deleting the cmos.ram file and letting it be recreated).

> If that doesn't work, can you let me know which rom it is (3.70 or
> 3.71) and post a copy of your rpc.cfg  (configuration file) here?

I'd tried holding Delete down before and had no noticeable effect. I
deleted the cmos.ram file and tried again ("sudo ./rpcemu") and got the
message "Could not open CMOS file '/home/david/rpcemu/cmos.ram': No
such file or directory". It then opened up a blue window with
"MIPS:292.8. AVG:30..." (the MIPS fluctuating).

My RO version is 3.70; the rpc.cfg is:

mouse_following = 1
cdrom_type = 0
cdrom_enabled = 1
blit_optimisation = 0
refresh_rate = 60
stretch_mode = 0
sound_enabled = 1
vram_size = 2
cpu_type = ARM710
mem_size = 32
ipaddress = 172.31.0.1


The cmos.ram file which reappeared after I quit the emulator is full of
nulls.

-- 

David - david atcost ukpoets fullstop net



More information about the Rpcemu mailing list