[Rpcemu] A pleasant blue window...

David david at ukpoets.net
Fri Mar 19 12:26:41 PDT 2010

In article <20100319161338.GA27953 at spod.org>, Peter Howkins
<rpcemu.howkins at marutan.net> wrote:
> On Fri, Mar 19, 2010 at 01:51:48PM +0000, David wrote:
> > In article <20100319110456.GA14027 at spod.org>, Peter Howkins
> > > Did this also fail in the previous set of instructions, when I
> > > said do this ... ?
> > 
> > Yes. I didn't think to mention it at the time. In fact, I wondered
> > if you'd just assumed I'd do the << aclocal automake autoconf >>
> > prior to the "./configure" and didn't bother writing it.

> Nope, this should have worked 'out of the box', as such it already 
> indicates something is up, so let's sort this out first.

> Start from fresh directory and follow the instructions from my post 
> before, if it still fails at the configure stage, can you give me the 
> output of the following 3 commands.

I assume you mean the post timed at 17:04.

No, it didn't fail.

> >pwd
> >ls -l configure
> >whoami

> Also, are you using the commandline 'tar xvfz rpcemu-0.8.6.tar.gz'
> command from the instructions, or some other method of decompressing?

I used Archive Mounter - tend to use the GUI where a method exists.

Might I suggest that if there is a difference in the outcome (which my
experience suggests there is), you ought to stress the need to do it
precisely as you say because numpties like me moving from RO to Linux
are almost certainly going to try and avoid the command line where an
alternative easier GUI method exists.

Incidentally, the 'make' resulted in lots of warnings. I've saved the
results (8.6KB) in case you want to see them.

When I test run it, I still get the RO error "abort on instruction
fetch at &02193040" - but surprisingly, no warning about !Boot not
having been run!

And still no Ctrl-End menu.

Adding in the 256MB blank hard drive image (using command line
'unzip'), I get the !BOOT not found message, as well as "undefined
instruction at &02195718"

Copy splug.bas & uniboot/zip into HostFS; create !Sparkplug & unzip
!Boot into Drive 4. Shutdown & quit; run again: gets as far as startup
(splash) screen without errors then just quits with Linux error:

 "RPCemu error: Bad opcode 36 73692029 at 219304C"

Hope this account is some help in understanding what's going wrong.


David - david atcost ukpoets fullstop net

More information about the Rpcemu mailing list