[Rpcemu] A pleasant blue window...

David david at ukpoets.net
Sat Mar 20 03:30:54 PDT 2010


In article <20100319234551.GA15023 at spod.org>, Peter Howkins
<rpcemu.howkins at marutan.net> wrote:
> On Fri, Mar 19, 2010 at 07:26:41PM +0000, David wrote:
> > In article <20100319161338.GA27953 at spod.org>, Peter Howkins
> > <rpcemu.howkins at marutan.net> wrote:
> > > On Fri, Mar 19, 2010 at 01:51:48PM +0000, David wrote:
> > > > In article <20100319110456.GA14027 at spod.org>, Peter Howkins
> > > > > Did this also fail in the previous set of instructions, when
> > > > > I said do this ... ?
> > > > 
> > > > Yes. I didn't think to mention it at the time. In fact, I
> > > > wondered if you'd just assumed I'd do the << aclocal automake
> > > > autoconf >> prior to the "./configure" and didn't bother
> > > > writing it.
> > 
> > > Nope, this should have worked 'out of the box', as such it
> > > already indicates something is up, so let's sort this out first.
> > 
> > > Start from fresh directory and follow the instructions from my
> > > post before, if it still fails at the configure stage, can you
> > > give me the output of the following 3 commands.

> I meant start from scratch and follow the instructions on this post,

> http://www.riscos.info/pipermail/rpcemu/2010-March/000806.html

Yes, that's the post I meant.

> Literally, step through it, follow each part accurately, and if any
> fails or appears to fail, stop, and post here.

My post, Message-ID: <50fa96a462david at ukpoets.net>, to which yours is a
reply, was the result of that process; and I did follow the
instructions precisely.

I suppose there were two points of failure: a) no menu, b) the bad
opcode error causing it to quit.

> I've tested this method, you don't even even need to hold 'delete' on
> reset at anypoint, due the cmos.ram that comes in the archive being
> correct for 3.70 and booting from ADFS.

> Also, reuse no files from any previous attempt or setup. Just step
> through the instructions with a completely new set, there's too many
> things that might have gone wrong in the past to compensate for in
> the instructions.

> > I used Archive Mounter - tend to use the GUI where a method exists.
> > 
> > Might I suggest that if there is a difference in the outcome (which
> > my experience suggests there is), you ought to stress the need to
> > do it precisely as you say because numpties like me moving from RO
> > to Linux are almost certainly going to try and avoid the command
> > line where an alternative easier GUI method exists.

> Until today I had no idea that a program called Archive Mounter
> existed. However in the instructions I told you to use the
> commandline 'tar' program. You really need to follow the
> instructions, else I'll have no idea if you're trying one thing
> whilst I think you're testing another.

Yes, sorry about that. I think you'll find that, unless they're told to
follow instructions precisely, most people are likely to interpret your 

| - Decompress src
|  >tar xvfz rpcemu-0.8.6.tar.gz

as meaning just "de-archive the source", seeing that you are using the
command line for everything but also knowing that GUI options to do the
same job exist.

And it's not easy to know when it matters or not. E.g. the Guide page
states:

| Create two directories in the rpcemu dir:
|   mkdir hostfs
|   mkdir poduleroms

Does it really need the command line to do this or will doing it
through the normal GUI method work just as well?

And, as for following instructions precisely, "mkdir poduleroms"
returns an error message that the file already exists. Does the
existing 'poduleroms' need to be deleted so that one can be created as
instructed (so getting rid of the emufs files)?

> > Incidentally, the 'make' resulted in lots of warnings. I've saved
> > the results (8.6KB) in case you want to see them.

> I'll possibly need to see them, but there's a couple of things to
> check first.

> > And still no Ctrl-End menu.

> Once you have managed to compile rpcemu can you post the results of
> this command.

> >ldd rpcemu

david at david-desktop:~/rpcemu-0.8.6/src$ ldd rpcemu
	linux-gate.so.1 =>  (0x0022b000)
	liballeg.so.4.2 => /usr/lib/liballeg.so.4.2 (0x00942000)
	libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00552000)
	libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0x00897000)
	libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0x00ed8000)
	libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x0013a000)
	libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x006d0000)
	libXpm.so.4 => /usr/lib/libXpm.so.4 (0x00365000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x008ea000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x00c2c000)
	libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x00110000)
	/lib/ld-linux.so.2 (0x00869000)
	libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00b9f000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x001f8000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x001a6000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x0039c000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x004da000)
david at david-desktop:~/rpcemu-0.8.6/src$ 

> And also tell me how you installed allegro on your system.

As far as I know by following the instructions on the Linux Guide page.

sudo apt-get update
sudo apt-get install build-essential subversion liballegro4.2
liballegro4.2-dev liballegro4.2-plugin-jack unzip wget

> Also, BTW, there is no better place than here for people asking
> support type questions. I have no problem with them being on the
> mailing list.

Thank you. I'm just sorry that the problem has generated such a long
thread.

-- 

David - david atcost ukpoets fullstop net



More information about the Rpcemu mailing list