[Rpcemu] merging RPCEmu and spoon edition

Peter Howkins rpcemu.howkins at marutan.net
Sat May 22 02:53:05 PDT 2010


On Sat, May 22, 2010 at 07:59:10AM +0100, Matthew Phillips wrote:
> In message <20100518134856.GC25187 at spod.org>
>  on 18 May 2010 Peter Howkins  wrote:
> > EmuFS is HostFS. But with multiple mount points and free-space calculation,
> > it's not a replacement, it's continuted development and a rename.
> 
> So have those improvements been included in the Spoon edition?

Not yet no, atm hostfs work is concentrated on passing the 'fsbash' test 
on the ROOL site (a automated tester that tries loads of different file 
ops). However we're now in a much better position to accept extra features 
into hostfs after having synced with Arcem (which passed more of the 
aforementioned fsbash tests than the old hostfs in rpcemu) and then fixed 
further issues.

> One alteration I had to make to EmuFS locally, in order to be able to use CVS
> under RISC OS, was making Unix hidden files visible to the emulator.  There
> was some code in HostFS which ignored any files with names beginning with
> ".".  I modified it to ignore objects whose filenames were not "." or ".."
> and things then worked the way I wanted them to.  I never committed these
> changes back to the repository.

It appears you wern't the only person that was affected by this. Tom 
Hughes submitted a patch and it was added a week or so back
http://home.marutan.net/hg/rpcemu/rev/30e49da10e06

> Another feature of HostFS/EmuFS which surprised me, when running on Ubuntu,
> was to do with NFS mounts.  I have my Iyonix's hard drive shared using
> MoonFish amd mounted via NFS on the Linux machine.  When I made the directory
> containing this mount point available to RPCEmu via EmuFS, opening the
> directory which should have contained the Iyonix's hard drive just resulted
> in a blank directory being shown.  I had hoped this would be a handy way to
> share the RISC OS machine's drives without going to the trouble of setting up
> ShareFS.

Hmm, given the flat fs model of linux, if a hostfs mountpoint worked in 
one place it really should have worked in another (the NFS mountpoint).

Peter

-- 
Peter Howkins
peter.howkins at marutan.net



More information about the Rpcemu mailing list